Back to overview
Downtime

Access issues

Apr 15, 2026 at 4:11pm UTC
Affected services
Buildstash

Resolved
Apr 15, 2026 at 4:51pm UTC

Our web application was briefly unavailable due to an AWS issue impacting one of our servers. We've now resolved the issue, and apologise for any inconvenience.

Created
Apr 15, 2026 at 4:11pm UTC

We're experiencing some issues with access to our web application, and are now investigating.