Back to overview
Degraded

Cloudflare downtime, some access issues

Nov 18 at 03:04am HST
Affected services
Buildstash

Resolved
Nov 18 at 05:01am HST

Cloudflare issues now seem to have been resolved and full access to the application restored. Issues persist with accessing Cloudflare's management services, but we are working on putting in place mitigations should access issues reappear.

Created
Nov 18 at 03:04am HST

We've seen some intermittent access issues over the last hour due to an outage with one of our infrastructure providers Cloudflare, which has taken down a number of major websites today - https://www.bbc.co.uk/news/articles/c629pny4gl7o

You can check uptime on Cloudflare's end here - https://www.cloudflarestatus.com - and we're working on mitigation on our end should these issues persist throughout the day.